Can`t connect PM5 - Pixel 4a - TD

I’m unable to connect to my PM5 (latest firmware) on my C2 Rower via Bluetooth. I have a Pixel 4a and the latest app version (beta channel) from the play store. Bluetooth connection with other apps is no problem (, KREW).
Can someone please help me?
Thanks, Marc

Hi Marc can you go to your Android settings and make sure it is not paired there? I will test it on my pixel shortly and see if I have any issues. We need to improve it so it will pair even if connected directly to the device.

Ok I had problems too. But I went to Bluetooth Android settings and connected it. And then connected with iPhone and disconnected iPhone and then Android worked. It works but something is wrong. You might uninstall and reinstall our app. Sorry about that. We will improve this asap.

Hey Alex, thanks for replying so fast. I don’t own a iPhone, so I can’t test your procedure. But I will test with reinstalling and connecting via Bluetooth-Settings first. BTW connecting via Bluetooth-Settings first will break connecting via

I am not an Android expert, but I connected via settings but after going back to remove it it did not show connected. I need to spend more time with Android and C2. iPhone should have nothing to do with it but since it was part of my process I mentioned it. I pressed connect a couple times on PM5 also.

Hey Alex, I had no luck connecting. I tried several procedures, even with another device (Galaxy Tab Active2). If I can help to test alphas or so, gladly!

Strange, thanks for the offer. Let me see if I can repeat this problem and if not we would love your help. I will let you know in the next day or so.

Can you contact me at Now that mine connects we can’t reproduce this issue so we can’t fix it. Your help would be very appreciated.

Probably the eMail is mis-spelled?

1 Like

Fixed. Phones and fat fingers…