Can't upgrate to premium!

I’m caught up in a loop here! I have a free account on Trainerday. I want to upgrade to premium… but can’t! Here is what is happening:

1- I go to and click “log in” then enter my info to reach the app page
2- On the app’s page, I click on “UPGRADE NOW”
3- This gets me to #pricing page and I click on “Sign up for our premium plan”
4- Which gets me back on the register page.
5- I click on " Already have an account? Log in here"
6- I get the message " You are already logged in!!!" so I click “go to app”
7- … and I am back to step 2…!!!

What am I doing wrong here?!

hmmm… weird! I just retried and something changed! When I get on the #princing page, I now see “Upgrade” under the premium plan and not the “Sign up for our premium plan” and it works now. So never mind; but still a weird problem!

Oh thank you. Yes someone else reported this too. I think it is some strange caching issue. I will fix this. Thanks for reporting.

I think I fixed it now. Thanks again. Closing this ticket.