Couldn't do a HR controlled quick workout (Tacx Neo)

I just tried to do a HR controlled workout on the latest beta version of the Android app, and I couldn’t get the app to control the resistance on my Neo. I put in a target of 125 bpm and it started with a resistance of 74 watts. After 2 minutes it stepped up the target power and i felt the resistance kick in, but almost immediately it lost all resistance control of the trainer, never to be regained.

In troubleshooting i did the following to no avail
unpaired and paired the trainer sensor
closed and restarted the app
uninstalled the app and left the beta, then installed again

In the end i had to do a TR workout instead and it worked fine

Not sure what’s going on, but it would appear to relate to the latest release as it was working fine before that

One other Neo user reported HR in Neo did not work. I think this is Neo specific problem. Sorry to hear. So you mean ERG mode did not work also? I have my Neo loaned out. I will get it back next week to make sure we are testing it more regularly.

Yesterday I did HR workout with a tacx Neo OG without any issue for 1h35.

Oh thanks so much for confirming. @potsiea1 Make sure your Neo is not directly paired to your phone in iOS or Android settings. Only paired in our app. We need to fix this issue ASAP.

The TrainerDay App was running on a Huawei P10 lite.

1 Like

Yes, the ERG function of the HR workout wasn’t working.

I don’t have any direct BT connections to the Neo 1

Phone is a Samsung S23


My tester tested the Neo on his samsung works fine. Did you go into Android Bluetooth setting in your phone and if it is connected say “Forget this device?” Not sure exact wording. I mostly use iOS.

I don’t have any direct Bluetooth pairings with the Neo, only through the app

I’ll give it another try today

Update. It worked fine today and I think I found the problem with yesterday, and it was at my end.

I am pretty sure there was a 3rd light showing on my Neo yesterday (the middle one), and I expect that was an error notification of some sort.

Sorry for not realising this yesterday.

WRT today’s workout, it took the full 20 minutes of the inital 20 min workout to get up to the HR target with the 120 sec steps. Seems a bit long to get up to target. I then auto extended for a total of 75 minutes, and the adjustments of power up and down were within a tight range which was great, and probably attributable to the long warm-up. So pros and cons in the new algorithm for me anyway

I believe you’ve nailed the reason, it’s a per-person dependent situation due to how HR lags vs power. For me, the HR can lag up to 20-30s before it catches up the the power I’m outputting.

Good news. Sounds like you are using the beta version. You should try our production version. We are doing a 120 second test right now. The prod one is 60/30 60 up 30 down. We will go back to 60/30 in beta early next week.

I tried to go back to the production version by leaving the beta group, uninstalling the app, and then installing the app again. But when I did this I got a message to say the beta version of the app is still installed and I should uninstall it.

Is there another way to roll back to the production version?

I just uninstalled again and re-installed and still get this message despite not being in Beta. See attached

Oh no. Sorry. I am not really an Android user so I don’t know how to “escape.” We will try to have beta version fixed Monday or Tuesday if you can wait. I did not expect so many beta users to be using this HR feature. If you don’t figure it out, I can try to escape beta also and give instructions. I do have Android for testing.

6 posts were split to a new topic: Zone 2: Heart Rate Adaption Speeds and Running vs Cycling


For future reference in case someone strikes the same problem, I had to Clear Data in the Storage settings for Google Play Store to let me install the production version again

Oh that is good to know. Thanks for that info. Since I am not Android user I don’t know all the tricks.

I was excited to try the APP, especially for the HR feature, but I must say my first experience was not good. I use Wahoo Kickr 6, with an iPhone. On the TV, I have a Apple Tv that runs Zwift, but only cadence and power, not controllable.

I set the HR to my preference. (why one is only able to change the HR in increments of 5%, does not make sense. I want to set it to a specific number.) Then started pedaling, it was like torture. There was no rhyme or reason, when my target rate was lower, it would drop the Watts, and when my HR was already above, it would further increase the Watts. I set, power smoothing to 5secs, I tried disconnecting and starting again, it only worked for a brief period, when I reduced my target HR below what I really wanted and when after 5mins, I felt brave enough, to up it by 5%, the craziness started again. Let me know, when you’ve sorted it.

Hi, sorry for your experience. You can go to settings and change it to 1% increases. It works well for many users. I only know of one other user that it does not work correctly for and I am working with him to try to figure out why. It’s something to with his specific heart conditions (post surgery) but still it should work for him and for you.

Do you have your threshold HR set correctly? I have Kickr V5 and works perfectly for me. Can you send me the link to your completed activity from our website?

Thanks, I changed the increments to 1%. Here is the link. There is one more that is shorter after I tried to restart.

That is very strange. What heart rate monitor are you using? My only guess right now is we are receiving zeros (or strange values) from your HR monitor and we filtering them from the UI and data but they are being processed by the logic. Just a guess as this is strange. I have one other guess. That our next version of our app will fix. We have 3.9.2 today but sadly that has a different critical bug…

Also what did you use for your HR target? We will definitely get this fixed.