Interval ranges missing in Garmin Indoor workouts

Hi. its been a while , when i last used TD workouts and lately i started using them again and i´ve got an issue. I remember that intervals were displayed as a range of power on my Garmin headunit and now they are a fixed power number( for example, riding at 200 w was displayed as a ± 5 w range or something, now its just 200w and thats it)
Am i missing something or it just is like that now?
Greetings from Estonia,
Vahur

Hi Vahur, good to hear from you. Sorry about that, we just changed our “outdoor” workouts and this is a new bug. We will try to fix this in the next week or so.

Sorry for the late answer, but good to know.
Keep up the amazing work you´re doing.

Should be fixed now

Hi. Seems like it doesn’t still quite work.
If a workout is sent to Garmin as indoor workout, it still misses the power range. When sent as outdoor workout, it changes the structure of a workout.
And when exporting a training plan to intervals.icu, then workouts also miss power range unless manually adjusting each one of them and unticking indoor workout and adding #outdoor to them.

Range is Garmin outdoor feature only. So it works as we designed it now but sounds like you want something else. I know we need to improve our outdoor converter. Are you trying to do workouts indoor or outdoor?

Is it ment to change the workouts structure when assigned as outdoor workout?
I’m currently doing my workout indoors, on Tacx Neo 2t via my Garmin Edge 530.
In spring and summer I do my workouts outdoor.
That’s why it’s strange, when I export my training plan, I’d like to have a power range.
Last year it had that if I remember correctly.

Yes most people outdoor prefer simple workouts. We attempt not to change the core training benefit, but right now the intensity can be off too much so we need to improve that.

If you are doing ERG indoors why do you need a range?

Indoors my Garmin beeps at me when I’m not hitting the exact power target :grin:
And as I said, when I export my whole season training plan, then when doing outdoor workouts it’s more difficult to hit those exact targets.
I liked it when building and exporting my training plan was a one time thing :grinning_face_with_smiling_eyes:
But I understand where you are going with the app and the site. It still is awesome what you have done and how far it has come.

Oh I see, strange no one has complained about this beeping as I assume others are doing it like you. Really we are not trying to force people to use our app. We like to let people train the way they like but at the same time we are trying to simplify which it is not easy to do both. I will have my tester test this indoor like you (I gave him my 530) and see how it goes. Maybe we will add a range to indoor as well.

I would love to understand any problems with outdoor mode as well.

Can I make our conversation public? If other people chime in they might have more thoughts on this.

Yes of course.

My tester just tried this and he has no beeping, I think you can probably turn that off for indoor training. See the video, it has sound but no beeps.

Okay, I will try muting warnings. The Workout range arrow isn’t moving also, but that is probably because there’s no range set, right?

I do some of my workouts on a Wattbike, which has good power metering but no ERG, so I need to adjust the power manually and with cadence. It would be really convenient to just follow the structured workout from Garmin (Fenix, I don’t take my Edge to the gym). So I would appreciate having the power ranges also for indoor rides. As an option.

Ok thanks for commenting. Good to understand different use cases. We need to test this and see if we just have only ranges if there is any negatives to standard ERG users. If not it seems like a simple change

I have exactly the same issue. My turbo does not have an erg mode and I push workouts to my garmin watch. As the TrainerDay workouts target a specific power, eg. 128W, unless I’m riding at that specific target, my Garmin is constantly beeping at me warning me I’m riding abive or below that target. If the power target were a range, it would fix this issue for me and others here I think.

Only just started using your app but love what you’re doing and subscribed straight away.

Ok great, more and more people want this it sounds and we will start researching to make sure it will not cause any issues but it seems like it should be an easy change.

1 Like

OK, I’ll raise the subject as well. What @vahursepp is all about looks like this, with a high degree of probability:


The beep is only there when you are on a different screen than the training graph.
If Garmin connections have the option to choose between Exact Power or Power Range, why limit this choice to external workouts? Some will want to have exactly to the watt then they will turn on the Exact Power, those who want to have the range will choose the Power Range.
As @vahursepp mentioned, since there was a power range before, why not bring it back? :wink:
Edit:
Okay, first of all, I wanted to apologize for this idiotic post above. It was the result of ignorance and mistakes. @Alex , sorry :slight_smile:
When I started with TD, I had Exact Power set to TD-Garmin connection. In general, it didn’t bother me until I persuaded my friend to use the TD. We have the same equipment and on his computer it shows the range and on mine it doesn’t. I changed the settings in the connection to Powerband. But it didn’t do anything, I still had no range indication on the computer. It wasn’t until I got sick with a cold that I went to Jack and told him he needed a few days off. I marked the days I needed to rest, wrote it down and sent it to the calendar.
Then the miracle happened and the powerband in the workouts appeared.
2024-02-07-15-11-29
2024-02-07-15-19-03
A question was asked earlier in the discussion, why do you need a powerband? Well, despite its shortcomings in training analysis, Garmin needs the indicator to be correct.
2024-02-07-16-29-38
So, to sum up (because you won’t find it anywhere): the power indication range works, and if it was previously set to Exact Power and then there was a change to Power Range, you should refresh the calendar by pushing the plan to the calendar again.