Kickr Snap/Saris not connect to App (Resolved)

Luckily it was Recovery day so I’m good to wait for fix. I’m not in beta program but if looking for volunteers let me know.

I can confirm I have the exact same issue: KICKR SNAP shows as paired but not connected no matter what I try. The KICKR works just fine with a WAHOO BOLT v2.

Please let me know if you find a solution for this issue :pray:

We think we have and will have new version in the next day or two. Very sorry about this. If necessary we can tell you how to install last version.

Hello Alex,
please tell me how to install the Version before the newest.
I had the same Trouble today.

Sorry about that. For Android read here how to join beta programs

Then if you go here you should be able to install the beta, it’s possibly you might have to uninstall the current one.

If you need iOS then I have to add you to the beta and installing older versions is easier. Send me private message with your iOS email address.


Two questions for you. First, if go back to the older version, none beta version, can we easily get back to the beta version once the update is in place?

Second, if we stay with the beta version, we should be able to export to say Zwift and then just mark finished in the app, correct? Then when we go to add more weeks to the plan, Coach Jack will see the data from Strava and include it with the other rides as expected, right?

So the previous beta version is 2.6.2 (the same version you were using until yesterday) and the current prodction one you installed was 2.6.4. We never deployed 2.6.4 to beta so the beta should not have this problem. Going back and forth you will not loose any features or functionality you care about. The changes in 2.6.4 were to fix Saris devices mostly and other small stuff so yes you can still mark as completed. Also leaving the beta program is easy after joining it.


I plan on staying in the beta but thought I would ask. I will just push to Zwift if needed.

I just had an update to Trainer Day and it says I’m in the beta program and the version is 2.6.4. The problem is Snap will not connect. I also logged out and back in but it still will not connect to the Snap.

So just wanted to confirm that 2.6.4 in beta should be fine? I’m including what the app shows as well.

Just an update. FEKieser tested fixed version and it is working. This should be available later today for Android and tomorrow for iOS (or today if we are lucky)

Marcus, here is a link if you want to load a fixed version. Uninstall the play store one first.

If you do not need it today, I would suggest you just wait until later today or tomorrow for update to the play store version. We have confirmed this fixes both Kickr Snap and Saris.

Ok this is available for Google Play store. Apple will probably take until tomorrow to be available but I we don’t have any confirmed issues with any iOS users regarding this bug.

Oh, today I couldn’t connect my Powermeter neither (Stages, cadence and power) through BT on the app, whereas it was connected as usual through ANT+ to the other app I use (BigRingVR). I rebooted my phone, my computer, twice, with no result.
PS: HR successfully connected.

Today I make a workout with my Stages Sb20 and everything work. without any problems

1 Like

7 posts were split to a new topic: Android 12 crashing with latest versions

Can you try our 2.6.7? It sounds like you have a different problem than the Android 12 users. What version of Android do you have?

Oops, no problem today.
Yesterday I was under v2.6.4. Today I think that it was with v2.6.5 (I didn’t check beforehand, only did it now, to reply to your message, 20min. after I finished my workout; don’t know if the app was updated before or after that workout).
Android 11 BTW, but that information is probably useless as my case seems solved.

1 Like

Today it didn’t work for me, after updating to version 2.6.8 I couldn’t perform my training, Stages SB20, I tested all possible options regarding the measurement of watts, with ERG ON or Off, it started well and then the watts 's dropped to half or started well and then went up to double,
the result was always the same regardless of the options selected, and I tested several possibilities of the sensors, in my case Android 8.0.0

Crap how is that possible? That’s terrible. We improved something with Android 8 and fixed one users problem and now it killed yours.

I think you can delete app and install this one and it will work but if not tell me and I will get you an older one.

Can you work with my developer early next week for 30 to 60 minutes? I will send you private message.

Hi Alex,

Today I decided to do a new test without changing anything to see if I could understand better why yesterday I couldn’t do the training, and miracle, everything worked perfectly, what a strange thing happened yesterday… I can’t understand

One other user with Android 8 says he has to turn off and on bluetooth some times, and he says he has the same problem with other apps not just ours but it sounds like our app has been stable for you and this is a new problem. Let me know if it happens again.