RPM dropouts with StagesBike (Fixed)

Hey folks,

Does anyone else use a StagesBike SB20 and have RPM dropouts? When I first started using the app around Feb there was an issue, then it was fixed… (see my prev post) in the last 3-4 months it has come back. Maybe every few seconds it’d drop to 0 RPM, which has no real affect AFAIK, although it often flags notifications and interferes with ramp tests etc. Apart from that everything works really good.



1 Like

Hi Grant, do you have HR built into stages bike? That must mean it is FTMS based HR or do you connect seperately to the HR monitor from the bike itself? One other user reported an FTMS HR issue but we have not looked at it yet. Please clarify or send us screenshot of your device connection page and we will figure this out.

Ah crap, sorry Alex,

I meant RPM. I’ll update the post.

BPM was on my mind since I did recently start using an HR monitor (which works really, well, by the way!)

Oh I am seeing this on Neo 2T also. We are working on this.

Do you have a screenshot of cadence from TrainingPeaks or Strava or something showing your RPM dropouts?

I don’t use Strava or anything like that sorry mate. But, I downloaded the tcx file, emailed it to myself and looked it in excel like a nerd. See attached. Let me know if you need anything else.

Can send me the link to your activity or the TCX? support@trainerday.com

You did that in excel from TCX? That is talented.

We fixed the Tacx Neo problem and hopefully if fixes your issue. Try new version coming tomorrow and let me know.

Hey Alex sorry for the late reply. The problem still exists I’m afraid.

I am currently running 2.5.0 on Android. Is this the latest version?

Edit: I just read that it’s still happening on the Neo. Bugger. Let me know if there’s anything I can do to help iron out the bug.

TCX attached.


Grantversion 2.5 - 60-Minute VO2Max - Classics HIIT.tcx (1.3 MB)

We have it solved I think. I am testing it in a few minutes and build should be out in next day or two.

I do know other users with SB20s connected both bike and left power meter to our app and it solved the issue but we are still working on a fix. You can see SB20 users group topic in our forums here for more info.

Stages SB20 owners group

Hey that’s awesome, thanks! - I’ll give that a go next time I’m on!

1 Like

Ok this 0 RPM bug should now really be fixed in version 2.5.4