A couple potential bugs I've noticed

Hey Alex and TrainerDay,

I just thought I would “log” a few things I’ve noticed on the app recently that seemed to be bugs or possible improvements on the UI/UX.

  • When in the app (app.trainerday), and you click on logo on the upper left, I expect this to return me to the “home page” of the app, rather than trainerday.com. This may be intentional, but I thought that if a user is in the app, that means they already have an account, so I expected it to return me to the app.trainerday.com default page.
  • If you copy a workout, and the original workout (not the copy you’re working with) is in a training plan, when you save, you get a prompt asking if you want to update the workout in your training plan, even though it’s not the copy in the plan. If you click “ok” it doesn’t mess anything up in the plan (the original stays the same) but it appears confusing at first.
  • Garmin connect doesn’t copy over “periods”. I think this is on Garmin’s side too, but if you send over a plan or workout with a . in it, Garmin doesn’t show. Ex: 1.5hr Endurance turns into 15hr endurance on Garmin. Note, if I push to Intervals and then they push to Garmin, the periods work
  • “Secure Connection Failed”, or “unsupported error” popup on W’bal calculator. This could very well be settings on my computer, but both my laptop and desktop, on Firefox and Chrome I wasn’t able to view this
  • Workouts won’t send to Intervals if they have comments on them. I wasn’t able to find anywhere this was talked about so apologies if so. I had a 30min recovery workout with comments, and it failed multiple times being sent to Intervals until I removed all the comments and the offsets

I had two others on there but now that I’ve looked around I found text hints that solved the problems for me :slight_smile: Thanks for all the work you guys do

Wow great findings Jeremy. I agree on home link (I just did the same yesterday in mobile view because I don’t usually use mobile view) and the rest should be easily fixed. We just removed periods and many other characters due to an issue but we will add periods back. Thanks again.

Jeremy I tried sending workouts with interval comments to intervals ICU and it works fine. It must have been something specific with your comments.

Here are a couple I sent no problem.

We are working on the “.” issue with garmin and the calculator SSL certificate problem.

CP calculator is fixed

Fantastic work. I just tried to replicate my comment issue and you’re right, it seems to be working fine so I’m not sure what I had done. I did get a warning once for “incorrect comment or offset value”, but all I did was copy and paste one of the comments (only happened once then I couldn’t get it to warn me again). What causes this warning to trigger?

Okay I actually figured out how to replicate it. The chance of this happening to someone may be slim to none. My guess is that there is a form validation that isn’t catching the updated “offset” value or pasted comment while using the keyboard. Let me upload a video

So what happens is when you copy a workout (copy workout), then copy and paste one of the comments. In this video you can’t see, but I am using ctrl + c and ctrl + v . The same thing happens if I select the text > right click (copy) > right click (paste) in the new cell

Yeah I think there might be an issue with comment offset in some specific cases. We just added more validation recently and made it so there should not be comments closer than 10 seconds together but in short intervals it might cause an issue if it is closer than 10 seconds to the end or something. I will ask my tester to test this. Maybe we should shorten the validation from 10-seconds to 5 for example. Good to hear it is working for you.

1 Like

Ahh, yep that makes sense. After reading your comment I attempted the same as the above video, but gave it more space (copied 2 intervals below rather than right below) and there wasn’t any warning so I was able to save the workout. I guess it doesn’t have to be a copied workout then, it’s just how I noticed it at first

@Alex One more thing I found, the modal for deleting a plan is positioned too far back. If you go to delete a training plan, the “edit plan” modal is positioned too far forward.

So when you click “delete”, the deletion confirmation dialog comes up behind the edit modal and you can continue to click “delete” and it continues to prompt a dialog. Eventually, if you click “done” then finally you can delete the plan.

I don’t have a screen recorder on the computer I’m on right now, but here’s a video from my phone


Jeremy, I don’t rememer if we ever fixed these. I am having guys look now. Hope all is well.

My QA says this all seems to be good, except the logo link to home page which was by design but I also click there not expecting to go to the home/home so think it can be better.