ERG/Free-ride button not working (bkool trainer)

Hi. I’ve just signed up and I have a Bkool Smart Pro 2. I’ve tried using one of the plans TD makes available, plus a workout I’ve used with other softwae and which I know works, but in the TD app, the ERG/Free-ride button is not available to click. It is there but is in effect, greyed out.

The turbo talks to the app as it records the power I produce, but it doesn’t change resistance. Interestingly the RPM feed isn’t working either.

I’ve used it on a couple of Android tablets with the same result.

Can anyone help please ?

Thanks

Hi,

It has already been talked about in another topic about it, I for example have a friend with the same problem and with the same model, it works well with all other applications except Trainerday, in short it works but without the ERG mode, which on the one hand it’s even convenient, and better approved to train with the ERG mode off

1 Like

Many thanks Joao. I appreciate the help.

1 Like

Hello again as I mentioned in email, and this is for other people if you want your Bkool compatible with virtually all apps you can get one of these devices. Sorry we are only focused on supporting the main standards, and we hope to support Ant+ but since that is primarily only for Samsung owners I still would hesitate to call it a standard.

https://npe-inc.com/cableinfo/

Hi Alex,

But this is for Ant+ connections and the Bkool model that we are talk is Ant+ and Bluetooth (BLE)

Yes but this CABLE device converts Ant+ to FTMS which is the current bluetooth standard for fitness machines. The Bkool has a non-standardd type of bluetooth. There are really 3-primary bluetooth types now. Neo + Wahoo + FTMS. Tacx uses FTMS for all their devices other than Neo for example and Wahoo is switching to FTMS.

1 Like