Hard to find today workout (solved) and slope doesn't work with new Kickr Rollr

After I got a new bike (that has bluetooth powermeter), I decided to try TrainerDay again. I purchased the Premium and attempted to do a workout.

  • First all my previous slope based workouts lost the slope mode (they were just regular ERG). Is this what happens when you cancel Premium, that all your workouts revert to simple ERG? I had to recreate a workout with slope to test.

  • Second, I added the workout to my calendar but when I open the TrainerDay app, it is nowhere to find?! I don’t know if the app changed recently, but it is impossible (for me) to find today’s workout. My only way to get it to work was to add the workout to my Favorites and then in the app go to Workouts, filter Favorites and there it was (had to scroll through them to find it). Is this the way? I would bet, it was easier than that half a year ago, wasn’t it?

Today shows some random workouts (instead of workouts from my calendar):

If I go to workouts, I didn’t see the one I created unless I add it to favorites:

  • Third, I created a slope based workout I don’t think the slope worked. Here it is:

But when I did the workout, nothing really happened when the slope went to +2%. Eventually, I had to switch to ERG otherwise it would be easy (0% slope for the whole workout):

Are these bugs or am I using the program wrong? I bet it worked before and it doesn’t seem to work right now.

Thank you,

Hi David, sorry for your troubles/confusion.

We will have to test automatic slope mode make sure there is no bug there.

What I think happened is you did not turn this switch on.

But also you should click on plan to see your plan, and pull down on the list to refresh.

Yes, Today should show from from plan but TODAY is a new feature and right now it is not showing from your plan. This is something we will be improving soon.

I hope that helps, we will test auto-slope mode today and make sure there is no bug there. If there is we will get that fixed ASAP.

Thank you Alex. I will try it again with your recommendations.

Sorry I mean to respond to to this. I recorded a video but going in and out of slope and ERG works fine for me. Maybe because you started with 0% that caused a problem. I did no test that. Maybe 0.1% would work.

Thank you Alex, today I did another try. I updated the workout to start with 0.1 slope instead of 0, but no difference.

In third interval, I even manually increased the slope to 8% but no difference. I then had to switch to ERG mode to get some workout.

After that I created a simple test workout and even though slopes were supposed to increase every 30 seconds, the effort remained the same.

No difference.

Any idea what could be going on? Is there some extra debugging information I can capture for you to further diagnose?


Oh I see, so it’s slope mode that is not working on your trainer. What trainer do you have? Once my developer gets through some current stuff (in a week or so) we could do a test session with your trainer. Maybe email me at support@trainerday.com to continue this if you want. I should research your trainer anyway before we work with him.

Ok TODAY will now show your planned workout. As we discussed in email we will keep working on slope mode fix for your trainer.