[Hopefully Solved] - Slowing Timer During workout

Lately when I use a workout that is around 60 minutes long, the timer starts to slow, when I get to around 45 minutes. i.e. 1 minute of riding takes 2 minutes. It looks like the timer is running in slow motion. I am using an ipad mini4 v 15.7.8.
Any ideas?

1 Like

I had the problem on my Ipad for a few weeks. But the last 2 workouts i did on my Android phone (Pixel 8 Pro) and have not had any problems with slow time when running TD on the phone.
Regards from Copenhagen, Denmark

1 Like

Sorry guys we found the bug. Will be out in next day+ I dream this is the end of 99% of our slow downs.


Just did a two hour basement ride (wanted to do three), TrainerDay app showed 97:12. My Garmin Edge 520 showed 135:06. This slow timer issue has been happening fairly regularly now. Time eventually runs slow after about an hour or two. Then time essentially stops. This latest time I tried pressing the pause and start buttons to try to move the clock along. It works for a few seconds but then stops. Consistently when the timer runs slow, the buttons for pause/start/stop are to semi-unresponsive.

My setup:

iPad Pro ML3N2LLA (12.9-inch) on 16.7.2


iPhone 13 MLN13LL/A on 17.1

Normally I use the iPad Pro. Tried the iPhone 13 for troubleshooting purposes. I thought I read that perhaps my iPad Pro is too old. The issue still occurs on my iPhone 13.

Garmin Cadence BT+Ant (latest hardware version)

Wahoo KICKR B6B3 - firmware version 3.4.68, hardware version 4

Polar H10 firmware version 3.1.1

Garmin Edge 520 {records the data that I use for analysis/social}

TrainerDay version 4.1.9 - note I try to keep up with the latest versions due to this issue

1 Like

Oh how depressing. We were really sure 4.1.9 fixed all the issues, especially on fast devices like your iPhone 13. Any chance you had a low battery? Or doing lots of other stuff at the same time?

@OSM_Fool Could you share your activity link?

I just had this issue too. It is definitely not SOLVED. Pixel 6a

Sorry to hear. Can you send link to your completed activity from our site?

I just had this issue too. It is not SOLVED. iPad Pro Gen 2.

It’s pretty annoying when you’ve prepared for a 2-hour workout and the bug ruins it for you after 90 Min.

Yes, the problem is when we test it on 3 different devices and it works perfectly for 3 hours it feels fixed. We did improve it a lot but it seems there are still random issues for some reason. We will keep testing.

I should say I have one more “good” idea on how to solve this that really should work in 99% of the cases. My guess is we are like 85% now but that is a total guess. Previously I was getting a lot of emails on timing problems and more forum posts now it’s you three guys. I can assume there are more. Still we don’t want this to happen at all. It’s definitely top priority especially since I don’t know how many people are affected.

I have the problem today, but he corrected himself lol
Around 3 hours into the workout I was almost 30 minutes “late” but suddenly the timer had to speed up to catch up, no impact here, but it has already happened to me on others or so I missed the blocks

Thanks, did you bring it from being in background for a long time?

No, the application always runs in the foreground on my phone and I don’t launch anything else to avoid application overload. Battery also at 100%

I see your workout has very spiky power but our smoothing should fix this, during the actual workout. I don’t understand. One thing you could do is once it gets past 70 minutes or so zoom out so you see the whole workout. We are actively working to fix this but since we now can’t reproduce it, it makes it harder but we are going to try by loading your workout data.

My developer is asking do you have any idea why this data changed like this? Is that when it started slowing down most likely or did anything else change?

How/where to send the browser link for the ride(s)? I also have the Garmin .fit files recorded with a Garmin 520.

By the way, based on posts in the their forum, Trainer Road users suffer from the same issues! Rides over 2 hours, slow clock, unrepsonsive app.

Just go to our website/activites/click on the completed ride, copy the URL in the top of the browser and paste it here. It’s better for us than FIT file. Thanks for info and TR problems :slight_smile:

Find below the link to my TrainerDay activity recorded with an iPad Pro 1st gen. I believe I was using the latest app version, 4.1.9 .

Goombah 3hr for 2h15m app running slow

The ride was supposed to be 3h long, I cut it off after 2h15m, as I noticed the stalled clock and erg power. I also recorded the ride on a Garmin Edge 520.

Yes I think it’s at that time too but nothing has changed, the phone remains placed in one place and I don’t touch it during my entire session… This morning 2 hours . workout and 0 problems

1 Like