HR, cad, power wrong display, stop resume helps but only until end of interval


I did an over under interval 90 minutes 5x9 minutes and at the begining of the 4th interval interval timer stop ( i use an iPad mini 2, tunein app play radio in the background but i did not quit from trainerday app), it shows low cad , hr and power data and those did not change. I turn off bluetooth and paired again, the app was very very very slow, but did not help. I closed the app and open again, WO was there i could continue, but the problem was the same and interval timer counts changed only every 2 seconds. After a few minutes i figured out that pause and resume helped but only the end of that interval, in next interval times counts 2 seconds steps and cad,hr,power was frozen, but by feel it was ok, so bluetooth should be ok, erg worked and changed power. So i finished WO and start again and finish the 5th interval without problem.

Could you tell it was a SW issue? I think BH was ok, because by feel erg worked, but display was wrong. And the WO diagram was

Hello, the current version of our app on in the app store is not very well performance optimized, so if you happen to have an older phone/tablet then these performace issues can affect you. We have a new version coming out later this week or early next week that is significantly better performance. This affects longer workouts more than shorter workouts. It looks like you have an iOS device?

I noticed a similar issue with my first interval workout on TD. On an older iPad, the data update frequency dropped to 5 seconds - but only when the workout graph was zoomed out to show the entire workout. (I thought it was a feature!) When I zoomed in it correctly updated every second. It was also slow responding to taps, eg, tapping to change the power readout from watts to %ftp took several seconds to change.

I switched to a newer Android tablet the next day and the app performance was acceptable.

Yes, iOS, ipad mini 2 is 7 years old now.

So i should not zoom out to see full workout? I will try if it occurs again.
I zoomed out because zoomed in times looks like not passing ang over under will never end ( fan fact zoomed out time really stops due to this performance issue :joy:).

I will update when it will be available and hope next 90 minutes WO will be ok.

The problem still exist after update, if you check the Strava screenshot WO started at 10:41 and movint time 1:19, so end would be about 12:00, but on the previous screenshot about Trainerday app it was 12:20, and i skipped a total 14 minutes interval!

As i remember it occurs about 56-58 minutes and started the feel time is not passing and remember to check this bug, after i zoomed in it looked like it works but reallly really not. I noted 12 minutesleft at 12:07 and at 12:11, so after 4 minutes there was still 10 minutes from that 12 minutes interval. So app counted 2 minutes instead of 4 mins and it was zoomed in and looked like ok.

Check this video when it zoomed out:

This version did not include the major performance improvements I thought it did. It did have timing improvements but since your iPad is both a mini and older it is likely performance related. We have a new version coming out in the next day or so hopefully that will fix this issule.

So to clarify you started at 10:41am, and it should have been 100 minutes not 80. Which you can see below

Yes, it should be 100 minutes. So please tell me the TSS for that 20 minutes that lost :smiley: :smiley: :smiley:
I got on the trainer and remembered that i should finish about 12:10 with the 90 minutes WO. I was curious if trianerday check iPad system or anything, but it looks like it is not, it just counts time and if it wrong then you can not see it is wrong. After Strava sync i thought there will be moving time 1:19 and total time 1:39 but not, it was the same wrong 1:19, so an other proof for me trainerday not sync to system time with iPad.

I will use my wifes iPad Air 2nd gen, Release date: October 22, 2014, i hope it will better with that.

We are testing new version today that hopefully will resolve this. You can figure out the TSS pretty quick in our workout creator. Looks like about 21 TSS more if you were at 80%.


I tried today iPad Air 2(nd gen, Release date: October 22, 2014) and the problem is the same.
You can see i started at 10:30 and finished at 11:46 and trainerday shows 71:27, 5 minutes missing. I started a timer and that count about 1hour 16 minutes.

Could you tell is there any workaround? I should not zoom out the intervals? Should not listening to tunein radio in the background?

Will it work on Xiaomi Mi 8 Lite android device or that is also too old?

Sadly I don’t think their is any workaround but not using zoom or going in background might solve it. I could also add you to our beta iOS group and you could see if our new version resolves this. It is much better performance and I believe this is performance related but since we can’t duplicate it on even the version of the software you are using we can’t be sure. Send me an email to support at if you want me to add you to the beta iOS group.