HR mode not increasing resistance at beginning


I did recently a 105’ workout in HR mode, and I must say first: no slowing timer so far. :grinning:
But it did some weird things at the beginning and the end.
I set the target to 122bpm, and started pedalling with high cadence, and I outputted about 130w, because I was in the middle gear. I think resistance was below that power. It seemed that either HR target was used as power target or HR target didn’t increase the resistance as I was pedalling more watts as HR mode wanted. So I was pedalling 5 minutes 130w with around 110bpm. No increase in resistance. After this first 5 minutes I pressed + and - to check if that helps, and it seemed at the first view that power = HR target, because with 140bpm target I did 140w. I switched than from HR to ERG and pressed there + to do the workout in ERG mode, but it started at 100w, and because I didn’t wanted to press so often +, I switched back to HR mode, and wanted to put HR target to power target. So set it to 160bpm, and boom power increased to 250w or something, had to decrease the hr target back to 122bpm, and then hr mode worked as expected.
I put TD in background while pedalling simultaneously in FulGaz. After 103’ I wanted to add 5’ and TD was not usable at all, it didn’t show the graph and was totally unresponsive. Pressed the +5m two times but didn’t see if it worked as it was unresponsive. I did a screenshot and there you see it added the 10m, but no graph and can’t say when the time was added.

I put it then back to background. But it immediately decreased the power to 130w again (as in the beginning), HR did go down below 110bpm, and no increase in power to get again to the target HR. But HR mode didn’t seem to work anymore. After 4 minutes I then changed the gear to the highest gear, to output some more watts (HR mode was setting the trainer still to the lowest resistance I think) and because of that HR increased then again.