iOS app won’t control Elite Direto

Running iOS on iPhone X. It pairs to my Elite Direto but does not control it.
The Direto is fine from other apps including RGT, Zwift, elite’s own app etc.
Any suggestions?

Hi Richard, we have many Direto users using our app. My suggestion is a firmware update on Direto. If that does not work you could make sure in the iPhone settings that it is not directly paired to the Direto. It should work even if it is but it might help. Let me know. This will definitly work some how.

Hi Alex. Thanks for the reply.
I checked and the Direto is already running the latest firmware, and I confirmed that the iPhone is not paired to the Direto. Also checked that no other devices like my Garmin Edge or laptop were connected.
But still no joy. Absolutely no control of the Direto from the App.
I last tried this back in August 2020. Then the Direto would pair but not connect. You did say that you’d had a problem with the Direto and other FTMS trainers, and were hoping to fix it shortly.
So it’s a puzzle isn’t it. Not sure what to try next.
(It’s the original Direto btw, not the XR in case that makes any difference).
Thanks again

Very strange. Are you willing to work directly with my developer? He can figure this out. Just email me at and I can set you up as a beta iOS user and we can work together to resolve this.

1 Like

Thanks Alex. I’ll do that!