iOS update required uninstall and reinstall (v2.3.0 only)

Today I used the App Store to update the iOSTrainer Day app to version 2.3.0 on two iPads and an iPhone. None of these apps would start. They all showed a blank screen. I have to delete and then reinstall the app on each device, login and then set up the app again.

Any idea the reason? Do you think logging out first would prevent the re-install step?

Very strange. One other user said upgrading to 2.3.6 he had to logout and login. We have not seen this. If you had blank white screen I don’t think you can logout.

I had the same had to delete the app and reinstall it.
I don’t think signing out of the app was an option when I tried to open it it just showed a blank white screen (the whole of the screen was white no menu bar was visible)

Strange maybe this had to do with our server issue. Did you update the app today or just try to use it?

It was a couple of weeks ago this happened to me and I can’t remember exactly which of the two actions below I did.

I think I updated then app (in the app store, I don’t allow many apps to update themselves I like to be in control so i often go into the store to see what apps are waiting for an update) then tried to open it and found it white.

but

I may have tried to open it found it white over then checked for an update then updated it and tried it again.

sorry can’t be more precise.

Similar experience here. I simply updated via the App Store - first on my iPads and then iPhone. All showed blank screens after update. I had just used Trainer Day successfully prior to updating so it is the new version that is causing the problem.

After deleting the app and re-installing I noticed that the login dialog was the first panel shown. Unfortunately, I didn’t think about logging out until I had updated all my app instances.

Oh ok if it happened to you a few weeks ago around the time of upgrading and happening today at the time of upgrading for others it must be upgrade related and not server issue related. This really helps.

Oh my developer had already fixed this bug. :slight_smile: But the fix is in the newest version 2.3.6 that is only in beta now.