[SOLVED] - Help with a new plan (Coach Jack not loading in some cases)


When I click on the start my first plan with jack nothing happens. I paid for the premium account.

What am I doing wrong?

Hi Dan, usually it is popup blockers, auto translation plugins or sometimes on iPad that it does not work.

So I’ve tried it on a MacBook, my android phone and my windows laptop. None of them work. The app runs fine the webapp does everything but I cannot create any workouts. What should I try?

+1 to this issue. I think it may be something up with the platform. I signed up for Prem earlier today and thought I was doing something wrong when CJ wasn’t responding.

Clicking/Tapping Coach Jack and it just doesn’t respond. No new page load or anything.

I’ve tested on a MacBook., two Windows devices, iPhone app + Android app (+ browser). Across 3 different networks and a few different browsers.

Edit: Tried with Edge this time and same deal.

Another edit: I should clarify that my attempts at using the apps for Coach just directed me to the website to create the plan.

Coach Jack is working ok for me. I’m on a Windows 10 machine.


Yes same the ‘learn more’ hyperlink also doesn’t respond on the CJ page either

We are investigating this.

Just gave it another go and was able to get progress.

From Meet Coach (Trainer Day) I was able to click Create New Plan and be brought to the builder asking questions. I was able to complete that process and save a plan to my account.

As @Dhurley33 shared, the Learn More link doesn’t respond. I inspected it on my browser and it looks it points to the same link as above.

My developer said this is fixed now. Since I don’t have this issue I can’t confirm. Please let me know.

Confirming Learn More issue also appears resolved. It now points to, and loads when clicked, TrainerDay — Learn “Everything” - TrainerDay Blog

Sweet!!! Ok that’s not the right link but it’s a step in the right direction :slight_smile:

Yes! Working for me now - thank you so much :slight_smile:

1 Like