TD FTP Ramp (Automatic) fails during warm-up (For kickr snap) (Resolved)

I tried to run the TD FTP Ramp test multiple times. Unfortunately, it fails during the first 5 minute warm up period. I never get to the ramp. I’m using a Wahoo KICKR Smart Trainer and the TrainerDay mobile app on a Samsung Note 10+. On other training sessions, I’ve noticed the RPM go to 0. I suspect that that’s happening during the FTP Ramp test, but not sure.

Yes somewhere during the ramp you will fall to 0rpm. I just did it last week and it worked fine.

Running on a lenovo tablet with an elite Suito trainer


There are a few trainers with some phones that for some reason have RPM drops (or watt drops) so this will cause the ride to end before it should. It sounds like you are seeing these zero drops. If you see them regularly if there is any chance you would work with my developer in a short debug session we should be able to get this fixed. If you want you can just clone our ramp test and rename it to not have ramp test in the title and then it will not end early but you have to manually calculate your FTP. Let me know if I can provide more info on either of these cases.

1 Like


If you remember, I had what I believe is the same issue a little while back. I would have some time to help on this Tuesday, Wednesday or Thursday morning early like before if you still need someone to help trouble shoot this.


1 Like

I notice that the RPM drops to zero in every workout multiple times. I’m sure it drops when I’m not looking too. I’ll be happy to work with your developer to debug the issue. Feel free to have your developer contact me.

Also, I’ll clone and rename the FTP Ramp test as you suggested.


Thanks Forrest, keep paying attention to see if it happens frequently. If it happens every few minutes or less then it’s good to work with Grigory again and he can fix it. It sounds like @vic has it happening every few minutes. Forrest because you worked with Grigory before it’s a bit more effiecient for you to do it so let me know but if not @vic can you confirm it happens regularly like this?

Just worked with Forrest on this and got it fixed. You will see fix in the next update of our app. Thanks @FEKieser :slight_smile:

1 Like

Ok this fix is released so Kickr Snap should now work with our ramp test. In this case it was with an external cadence sensor.