Wahoo Kickr Gen1 settings

This one is a bit niche so bear with me!

My old 2014 Kickr is currently taking ages to warmup in the UK cold weather (I use it in a shed) so the power resistance is awful for 20-30 minutes and undershorts by 30% then gradually improves, after that it matches my Assioma pedal readings just fine. Thankfully I can increase the power on the fly in the app to compensate. I’ve tried the various warmup up and both spin down options but neither has helped from what I can tell. The Kickr is fine as it works fine in the house and fine after it has warmed up.
But there are numerous settings in the app and also in the Kickr app for the device. I’ve currently got the Kickr reading power from the Assioma pedals (using the ant+ power setting). I don’t have the Assiomas as the power data source in the Trainerday app. I basically have their power showing on my Garmin head unit then manually match the power in Trainerday using the + and - until the power readings converge.
So, has anyone experienced this coldness scenario and got a better fix? Advice appreciated!

Hello again, do you have power match turned on in your settings? My fluid trainer usually starts off cold and takes a while, but the power match feature has been doing a good job with it (I just notice that the power difference gets less as time goes one). I have the assiomas as well

Yes as Jeremy suggested just turn on power match. Should solve the problem for you.

Okay, should I connect my Assiomas to the app as well? And should I turn off the Wahoo Kickr, read power from ant+ device also? I get confused as there’s a lot going on!

Just connect everything that you’ll be using to the app (Bluetooth), then make sure Power Match is turned on in the settings. TrainerDay will take care of making sure the power is coming from the correct devices :slight_smile: You shouldn’t need to make any other changes, but yes make sure all devices are connected via Bluetooth with your device

Okay, thanks. I’ll try that. But I’m sure I already did. Will pay more attention this time and perhaps disable the Kickr read power from ant+ setting in the Wahoo app just in case. I’ll update in a couple of days. Thanks so far!

Good luck! Keep us updated :grinning_face_with_smiling_eyes:

btw, I’m not affiliated with TrainerDay except for the fact that I use the app. Sometimes I feel i’m giving the impression that I know what’s going on behind the scenes - which i do not. Just giving some ideas based on what I’ve seen and feel might work based on similar technology

You should see something like this below on your screen


Oh wow Alex, that makes it really clear. I’ve never seen that before, maybe I didn’t have powermatch enabled when I thought I did! I’ll update later, or maybe tomorrow.

Thanks Jeremy. I didn’t think you were affiliated, not that it would matter, I did assume that you had some knowledge though. Anyway, I’ll update later to tomorrow. Work is a bit busy today so I don’t know when I’ll fit my training in!

That sounds great! Btw if you’re not seeing the powermatch or your app is a little bit out of date, there’s a good chance an update might fix your query regarding the warmups as well (thus fixing the merge/cancel issue)

Hiya. Just reporting back after enabling power match. It’s definitely much much better but now I’m curious about the numbers displayed in the powermatch box, what the first watts number (with a + or -) then what’s the number in the brackets? I’m also a bit curious as to how regularly the powermatch is running its calculations.

I’d say there’s a bit of lag that’s especially noticeable on short intervals but that’s probably the Kickr’s response time. I can certainly live with that.

Yes we actually have a lag built in so that it does not make radical changes until things settle down. But Kickr has lag too. ± means the amount of adjustment and in brackets that is the actual watts being sent to your kickr.

Great, thanks for the explanation.

1 Like