Day 1 still current day after completing workouts (FIXED)


so just recently I started a membership and created a plan with Coach Jack.

Just now I completed my second workout.
During the first workout I was curious what the arrow button, next to ERG, does and clicked it. So an interval was skipped to the end.
Today somehow the connection to my Elite Suito trainer was bugged and the reistance did have some serious drops and didnt adapt well. After restarting the app and the trainer it worked. I skipped the warmup intervals.

However when opening the mobile app the first workout in the plan is still shown as the current one.

What are the metrics to jump to the next workout as the current one?
For now I have two workouts not done for.the whole duration.

I attached two screenshots from my mobile. I rened the first workout, just for clarity.


Heres the second screenshot

Hi Mattias, great to have you. That sounds like a strange case. I need to check this next button to the end and see if there is some bug there with regards to completing it. When you get to the end of the workout no matter what you should see a screen like below. If you leave the checkbox checked it should be marked as completed. Let me know if your save dialog looks like this. If you see this and complete the 3rd workout it will still advance you to 4th.

Thanks for the reply Alex, I will check it tomorrow after i finished the recovery ride.


Ok my developer found a bug in how this completed planned workout logic works and fixed it. This should resolve your issue (if it is not already). It will be available next week some time. Thanks for letting us know about this.

1 Like

Hi Alex, thanks for the info.

Yesterday I had my day 3 workout. Afterwards the current marker was on day 4.
Today I opened the app and day 4 was still current.
I then closed the app via the app overview on my tablet and opened it. Day 1 wass current. Hopefully this was the mentioned bug.


Strange, thanks we will find this problem too.

1 Like

I’ll try to make a screen recordidng of this issue the next time I ride

Oh I misread this. It is hopefully the same bug. I can ask my developer if he thinks it is. But if screen recording is easy that would be great.

Hi Alex

Here is the video

It is not listed

Strange thing is that it is showing the correct workout as the current one until the sync is completed.

Hopefully you and the devs can find a fix


Thanks so much for the video. I think they have it fixed but I sent this video just to make sure. We will launch never version of app this week with our fix.

1 Like

Ok new version of app is out. Hopefully this is fixed for you now.

Which version is it?
I have the the app updated on Nov 29th and the bug is still present.

That should be it 2.5.6. If that is what you have is there any chance you would be willing to work wil my developer a little?

Same problem here.
Today I finished my “Day 4”; after reading that post on the forum, I launched the app to check if there was any change, and “Day 1” was selected :face_with_raised_eyebrow:
I noticed that issue at least since the beginning of this week: every day when I want to follow the next workout, it sets me back to “Day 1”.
V2.5.6 BTW.

I have to say I’m having the same issue. A look at my History tab shows just did Day 10 but when go to start a ride it picks Day 1. I’m on v2.5.6 as well. It also happened this morning when I rode Day 10 as it should have picked Day 10 but was at Day 1 so manually had to pick it.

Hi Alex,
I have version 2.5.6 too.
Of course I would like to work together with you guys to resolve the issue.


I had an idea. Are you guys both following a recently made coach jack plan?

I made a custom coach jack plan ablut two weeks ago

1 Like

My plan is two weeks old. Begin third week on Monday.

1 Like