Help needed - ERG mode

Hi there,

I am seeking some help with some readings as I’m fairly new to Trainer Day (having converted from Zwift).

For background, I’m using a Wahoo Kickr Snap V2 (which I’ve calibrated), using Trainer Day on mobile and syncing a workout through Training Peaks.

My understanding of ERG mode is that the resistance on the trainer should adjust to match my cadence. A key focus for me is raising my cadence (as a novice, I’d been sitting really low - at around 60/65).

The problem I’ve run into is that when I lift my cadence (my goal was 90-95), the ERG mode doesn’t seem to kick in and my wattage goes through the roof, which meant that, in my ‘Zone 2’ warmup (supposed to be at 230 watts) I was riding at roughly 30watts higher for the 20mins, even at a lower-than-goal cadence of ~80.

That was a fair bit of extra work to take on before my intervals! Which brings me to my question - what am I doing wrong? I’ve attached a couple of screenshots from Strava, Training Peaks and Trainer Day which hopefully help explain the story. You can see that when it got to the interval I had to drop my cadence way down so I wasn’t sending my wattage through the roof.

Ideally I’d love to do all of the ride, 180w warmup, 230w extended warmup, then intervals at 287w at a high cadence around 90RPM, but at the moment that seems impossible?

Quick note: the drops at minutes 18 & 24 were deliberate. I thought by restarting perhaps the power would match my cadence but unfortunately it didn’t work.

Hi there, yes something is wrong. If you increase cadence in ERG mode the watts should stay the same unless you are in too big of gear, it’s slighly possible the trainer can’t lower the watts enough. Make sure nothing else is connected to your Trainer, meaning no Ant+ devices connected to it.

Hey Alex,

I actually had it in one of the lower gears on the small chain ring to avoid this issue.

I did have my headphones connected through Bluetooth with music playing on my phone, as well as the trainer running on my phone.

Perhaps I’ll try running it on a different device to where my music is coming from?

Also would it help if I hit ‘lower resistance’ so the ‘goal’ on the ride would drop, even though I still know that the overall goal remains the same?

Bluetooth headphones can definitly cause issues. Sorry, I did not respond on cadence. I would not focus on cadence at all. I would ride at your natural cadence. Once you have been riding a while you might try some cadence drills. I know older guys that are super fast with low cadence. I have read articles that many pros have low cadence while hill climbing. The #1 thing to focus on is your aerobic system and the best thing you can do is slowly increase your weekly hours and ride at zone 2. You can do some other intensities for short periods just for enjoyment but you will get the most benefit and least negatives from zone 2. Build your base for at least 3-months. I would suggest longer. You will hear a lot of mis-information out there but taking it easy so you don’t feel your breadth and slowly increaseing weekly hours is most important.

Hi Alex, no worries - take that note on cadence. I’ve been told by multiple sources now that a higher cadence will benefit me long term. I’ve been riding for a few years now and just getting into programs with a huge focus on Zone 2, so take the point there.

Ideally, no matter what cadence it would be great if the ERG mode matched my cadence and allowed me to ride at my goal wattage. Will try removing all bluetooth devices from my phone next time when running Trainer Day and see if that improves the situation!

Yes for sure that is exactly how ERG works. You should be able to fix it. A few people have reinstalled our app and it fixed issues but more likely a Bluetooth issue.

And I am not saying a higher cadence is bad it’s more like icing on the cake. Cycling is 95% aerobic (air utilization by your muscles) so my point is that should be the focus. Skills work can be fun and have performance benefits as well.

Hey Alex, appreciate the responses!

Did another ride this morning. Calibrated the trainer, only had the trainer connected to my phone via bluetooth (connected music halfway through as it made no difference) and had power smoothing to 5sec. The workout was 5mins Zone 1 (179w), 50mins Zone 2 (230w), then 5mins Zone 1 (179w).

Unfortunately, the issues persisted. As you can see from screenshots 1-3, I actually dropped the resistance manually by 10% so that I could account for the blown-out wattage. It started okay but the wattage crept up insanely. In screenshot 3 you can see I was 53w above where the ERG mode should have had me.

It got to the point where eventually I had to drop to 80% manually (screenshot 4) during the Zone 2 piece in order to stay anywhere near 230w. I did this again for the warm down (screenshot 5) so I could warm down without toasting myself.

It feels like the wattage read is correct (I can tell when I’m doing 230 watts) so I’m not sure what the error is here?

Has anyone else had similar issues or is this just me? I may just have to ride without ERG mode from now on or try a different provider if I can’t get this sorted. Any help is appreciated!

So just to be clear this is only the trainer connected and no external power meter?

Sorry Alex, yep. I am using left side power pedals (Favero Uno)

Ok that is why this is different. It’s “normal.” You can turn on our power match feature. That will slowly adjust your trainer to match your pedals. It works reasonably well for longer less intense intervals. Generally the way this works is we tell your trainer to target 100w but your pedals might show that is actually 110w. Power match attempts to fix this.

1 Like

Okay Alex. Thanks for this. Will give it a try!

Hey Alex, me again. I tried the Power Match and it was a bit of a disaster.

Once the Power Match kicked in the trainer started to struggle and my wheel was spinning but also getting stuck. It was as if the trainer was jerking back and forth. I was well under the required wattage, but it was incredibly hard to even get the pedals moving. Really frustrating. I had ‘power smoothing’ to 5s and ‘Double Single Sided Power’ on. I also tried without ‘power smoothing’ and there was no difference.

Can you explain why the Power Match is +110w? I don’t understand how this works, but I’m really keen to get it figured out as it’s untenable where I am currently.

Power Match +110w means that the algorithm detects a difference between the power reported by the trainer vs the power reported by the Pedal Power Meter (assioma in your case)

So, if powermatch is saying +110w, it could likely mean.

PowerMatch Disabled. Target Workout Power = Trainer Power
Target Workout Power = 210w
Power from Trainer = 210w

Power Match Enabled:
Target Workout Power = 210w
Power from Trainer = 210w
Power from Assioma = 100w <=== this

when power match is enabled, the trainer will use the Assioma Power as “standard” and correct the power sent to the trainer to ensure that the “Target Workout Power == Assioma Power”

In this case, I believe that the power from the assioma is showing 100w, vs the desired 210w target. So an offset is needed to push the assioma to read 210w

After Power Match Applied:
Target Workout Power = 210w
Power From Trainer = 210 + 110w(offset) = 320w
Power From Assioma = 100w + 110w (offset) = 210w

1 Like

Okay, that all makes sense now.

It doesn’t explain why it’s actually impossible to ride when I have power match on. It’s really jerky - is there a way to bring them closer together?

Also in your example with power match off, this is not how it’s occuring for me.

With Power Match off, the ERG mode sits me at up to 50w higher than the zone it’s supposed to (see screenshots above).

There’s something really, really wrong here but I just can’t figure out what.

You mean this?

if Power match is turned off, there might be issues w/ your trainer holding the power. Your initial post says kickr snap 2 and alry calibrated. So that’s a hmm…

did you try with some other app like Wahoo’s own app and does it able to hold the “correct” Target power and it shows the same power on say your Garmin device?

It is a big hmmm… I did a factory reset and calibration on the Wahoo Kickr Snap V2. No change in the separate issues with/without Power Match.

I ran it through my Garmin Edge 130+ (on indoor mode) and the trainer picked up my cadence changes and adjusted the resistance accordingly. So from where I am sitting it would seem to be a Trainer Day issue?

Cadence change typically should not have a large impact towards ERG mode.
Can you instead design a workout that’s like a Ramp Test and see if the values match?

Target Power - 1min - 50w
Target Power - 1min - 100w
Target Power - 1min - 50w
Target Power - 1min - 100w

Technically you should be able to see the Power from Trainer match the power from your assiomas.

I think this CIQ app supports your Garmin. It allows you to “side by side” record 2 power data into 1 single session. I think you can then review the data within Garmin Connect to see if all matches up.

I just want to confirm - what answer will this give me? Whether or not my pedals are working? Because I’ve been on outdoor rides and they seem to be working fine in that scenario.

I admit I only gave the full article a cursory glance, but can probably find some time do this on the weekend.

It’s even easier. Send a workout to your Garmin with fixed power set at e.g. 100W and run it with your trainer paired to your Garmin. You could even simply create a workout on your Edge if the 130 allows that.
The trainer will be set at 100W and your Garmin will display power from your pedals because all Garmin units prioritize “real” power meters when multiple sources are available.
You will immediately have an idea on the difference between trainer and pedals. If the difference is big (more then ~50w), PowerMatch will not work well. It works very well when the difference is within 10-15W.

Second thing to check: In the Favero app you can set the handling of single power over BLE. It’s better to double the single sided power in the Favero app. Then make sure the same setting is disabled in the Trainerday app.

If you still have problems, disconnect the pedals from the TrainerDay app and check if everything is working correctly when only the trainer is paired to TrainerDay. You can run your Garmin simultaneously to display the power from the pedals. BUT in that case make sure that the trainer is NOT paired to your Garmin because the Garmin and the TrainerDay app will fight over the control of the trainer and results are unpredictable. It’s probably better to first test with the Garmin shutdown to make sure it is not interfering.
Let us know how that turns out.

Okay, well tomorrow morning I’m going to do this workout through my Garmin edge 130+. Are you saying that while I’m riding, if the ERG mode works well and sticks to the targeted wattage, the power meter and trainer are closely aligned on power?