Push to Wahoo Devices (Finally)

See below you can now push workouts to wahoo devices. Two steps

  1. Go to our connections tab and connect to wahoo

  1. Push the workout

It will show up on your device for today.

5 Likes

Hammerhead Karoo next? :wink:

There there there
I just quit the platform and now this gets in

I’m back :smiley:
thanks

4 Likes

I probably need to buy one if we do :slight_smile: I will start looking into it a bit.

1 Like

+1

1 Like

Hi @Alex
Good to hear we can push workouts to Wahoo devices. That’s the one I was waiting for.
I have tried to connect my TrainerDay account to my Wahoo account a couple of times the last 2 days. When I press authorize, I get an error message in TrainerDay:
“Looks like you didn’t select the required permissions to work properly.
Please try again or contact support. "
and the following message:
" Your Wahoo account requires reauthorization.
Open Apps and Devices page to re-connect.”

When I look in Wahoo (www.wahooligan.com/profile), I see that TrainerDay is connected with the correct permissions. See the screendumps included.

Do you know what the problem can be with my permissions (accountname=bertus_f)?

Ok strange, it works fine for me. I just tried it again. What browser are you using and do you have any plugins installed like blockers or translation plugins? I will have my developer look also.

Hi Andre,

It is strange indeed. I tried to connect via Safari, Edge and Firefox on my Mac (everything is up to date). I also tried it on my iPhone using Safari. And on an old Android. Both via wifi and via the mobile network and both with and without VPN enabled. Also tried VPN enabled from other countries. Nothing helps. I thought I tried too many times and maybe Wahoo has a maximum in api calls per day. This maximum in api calls is on most platforms set as a maximum per day and the total will reset at noon. Today I tried again, but with the same messages. And a new one. See below.

Maybe the developer can check the log files for answers.

Thanks for answering so quick! I appreciate it a lot.

Greetz,
Bert

This is our error, it looks like our code crashed some how. It might be related to api throttling but this should help my developer understand.

Hi, I’m new here, I have the same problem. Can I do anything to solve it or do I just have to wait till the problem is fixed?

Kind regards Georg

Looks like you have to wait. Hopefully we can have it fixed early next week.

1 Like

Ok we see the problem but not exactly how to fix it yet. But it should be soon. It’s something to do with rate limits but I think it is our bug not theirs.

It seems to work now, more or less. I created a totally new account in Wahoo and now I can sync my TD workouts directly to Wahoo. My old Wahoo account had more problems connecting and syncing with other platforms (Stryd, Intervals.icu, Trainingpeaks). From Intervals.icu, I had dozens of the same workouts in my Trainingcalender on both my Rival and Bolt devices. Anyway: my subscribtion just ended with Wahoo, so it was no problem for me to use a new and clean Wahoo account. And now it works very smooth!

But I still have 2 issues:
First: I don’t see that TD and Wahoo are connected on the Connections page. I still see the button: CONNECT TO WAHOO (BETA). But on de Wahoo profile page, I can see that there is a connection.
Second: I cannot send specific workouts to my Wahoo devices, when I use the ‘send to’ link when a workout is opened, I see Wahoo (beta) greyed out.
The good thing: When I plan a workout in the TD calendar, that workout magically appears on both my Rival and Bolt device. And that’s enough for me.

I hope this information helps in finding the solution.
If some testing is needed (with my old or new Wahoo account), you can contact me.

I have not even talked to my developer about this but I did not realize that sync to Wahoo from the calendar was even working… I am going to talk to him shortly. Thanks for clarifying. This is very strange but helpful.

Ok my developer says you are smoking crack :slight_smile: Meaning we don’t have a sync from calendar to Wahoo at this time. You must be syncing to IntervalsICU or TrainingPeaks and they are syncing to your Wahoo. Also, can you try re-connecting to Wahoo. My developer believes he fixed the problem to fix “send to wahoo.”

Yes I was smoking crack, or better: weed (I live in the Netherlands, where it is legalized). I tested again and your developer is right: the workout is first syncing to Intervals.icu and then to Wahoo. My mistake!
But the problem I described, still exists. I tried to connect with Wahoo again from TD, but with the same results. The connection button doesn’t change and sending a workout to Wahoo is greyed out. I also don’t see the TD permissions in my Wahoo profile, while in my previous attempts, all the permissions were registered. But it seems to work, because in TD, I see a short message on top of my browser window that a connection has been made, after I try to connect. But the message is not correct, there is no connection at all.
I will try again later today/tomorrow.

Weed is way better :slight_smile: I used to live in Haarlem but sadly I had already stopped weed when I got there.

Try again. I disconnected your wahoo account in the database. Let’s see if that helps.

Haarlem is a nice city!
Thanks for disconnecting my Wahoo account, but after making a connection again, I still get the same results: no connection in the connections tab and sending a workout to Wahoo is greyed out. I do see the TD permissions appear in my Wahoo profile, but that’s it.
It seems like there is a connection between TD and Wahoo. Can you change a Wahoo parameter in my account settings (eg change Wahoo connection status from 0 to 1)?

When you accepted the connection did you click all the boxes for approval? I think my developer has to look and figure out what is going on. There is no setting I can change.