[SOLVED] - ERG Mode not working (Tacx Flux)


I am a recently new member. Was very eager and bought my 1 year subscription, Unfortunately I notice that the ERG (and / or Slope) mode are not working. I removed the app from my iPad and downloaded it again. I am on the latest version. My Tackx Flux 2 is on the latest firmware as well.

It doesn’t matter if I use Slope or ERG mode. There is no difference. In ERG I need to shift gears to get a higher Watt as well as in Slope. This ride I used ERG mode for the first 20 minutes, then Slope for the next 15 minutes and ERG for the last 10 minutes again. There is absolutely no difference in behaviour. Can you or anyone help me with this? It is a crucial function for me to keep using the app.

Don’t worry I will refund you if we can’t get it working. What is really strange is we recently fixed it for one Flux 2 user and it broke it for another flux 2 user. So we have new fixed for the second one which my guess will fix yours. This build will be on this week. Hopefully in the next 2 days. Sorry about that, I am sure a big let down after being so excited. Really we will make sure it works for you one way or the other hopefully right away. I can always add some time to your subscription.

Thanks for your quick reply, I will wait for the next fix no problem. If I can help with providing more details just let me know !

1 Like

Thanks. I have the same problem with Flux Tacx 2.
Only in iphone!. FYI.

Ok let’s hope our fix, fixes this. I think it will. Should be available tomorrow.

1 Like

I will tag onto this one. My wife uses that same trainer and also no matter ERG or Slope mode no difference. Ditto cadence. All over and not able to hold the power at all. Also on iPhone.
I myself have kickr and zero issues. We were going to get her a subscription but not until this is fixed.
Everything works well on ROUVY and Zwift.

The version is out that fixes this problem. If anyone still has problems let me know.

1 Like

Thnx, will check this afternoon if it is available in the store and test

1 Like

I thought I updated the app, but when I was finished it said again update in the store. So hard to say, for now no change but can be due to failed update. Will do a new run tonight or tomorrow. Keep you posted.

Hi Alex,

I ran into a similar issue with ERG mode not accurately controlling a Tacx Flux S.

I confirmed the trainer responds to ERG mode as expected when using Trainer Road and the Tacx Training app. I didn’t save the TD rides, since I was only testing basic app functionality, but I can re-ride and save if it helps your team troubleshoot. Details below.


  • Version: 4.5.0, Free
  • Other Options: Enable Auto-Extend Cooldown “On”, all other
    options “Off”
  • Workouts: Early & Varied; Cockaleakie Sliding

Tacx Flux S

  • Firmware: 3.3.40 1.1.6

iPhone 11

  • iOS 17.2.1

My plan is/was to replace TR with TD and am hopeful the ERG bug can be sorted.

Thank you!

Ok since you tested 4.5.0 that means it’s still a problem. I need a volunteer from this group to work with my developer. It’s really strange we fixed one flux and broke others. If someone can meet 1:1 it should only take about 30 minutes. Maybe even less. Just let me know and I will send someone a PM with details on how we can connect.

Hi Alex,
I can help out if need be. I can jump on my wife’s Tacx Flux and see where this goes.

That is great! I will be away tonight, can do something this weekend if needed. Hope something will pop out with your session @soupman39 . Thnx for taking the time!

Yes working with Tom (soulo_ridah…)… If we need you we will let you know. Thanks for the offer.

1 Like

hi groennom.

I’ve got a flux 2 which I’m using with a new(ish) iPad and have experienced the exact same problem but I’ve made two changes and have managed to resolve it.

the first change is that I no longer use the same iPad to run my music (Spotify) playlist as I do to run TD. the speaker connection seems to interfere with the trainer connection and so I now use my iPhone to run the music completely separately from the trainer/iPad combo.

the second change is that I run a calibration routine each time I use the trainer. this is a bit of a pain but it only takes about 30seconds and has now became second nature. in case you’re not sure about the calibration (sorry if you are, don’t mean to patronise) you do it in the Tacx app without the TD app running. you then quit the Tacx app and launch the TD app. it’s quite important (I think) that you don’t have both apps running at the same time.

I hope all that helps. good luck.


Hi @jongetz thnx for the tips. I did run a calibration in the Tacx app after I experienced the issue but will try to do it again. Music I do via my iPhone. Will let you know in a couple of hours, will do a ride shortly,

Just did a 75 min ride an no luck. Closed the app on my iPad, calibrated in Tacx and drove. No luck. Also tried it on my iPhone, also not a positive result.

Was a nice training ride, but would love to have the ERG working :slight_smile:

good luck. Jon

ah, just seen it didn’t work. sorry to hear that. not sure what else to suggest. Jon

We see the problem and think we have it fixed. A new version should come this week.

1 Like