Intermittent target change problems using ERG

Hi there, hoping someone can help. I’m getting an issue that when in ERG mode the app is sometimes not moving onto the next interval. For example I will be doing a 30 second interval at a certain amount of watts then once the 30 seconds is up it moves onto the next interval but the watts stays the same even though it should go up or down. Using Saris H3. Tried it on both my old iPad air 2 and my Google pixel 7 pro and it does it on both.

Thank you!

was this an issue on previous versions or just on the recent versions?
It may be helpful to provide additional details so @Alex can hunt it down specifically.

Also - did you try a Watt increase / decrease manually when it happens to see if that will unstuck it?


Hi @rcollins500, I’ve had the same drama. I did 12 x 1min intervals, with a 2min break in between and when it ramped up for the 1min intervals I had to pause the session, spin the wheels backwards then spin them forwards again to feel the resistance change then un-pause.

Really annoying! If there’s a fix I’d love to hear it.


1 Like

Sorry to hear guys. I know this is super irritating. It seems to affect specific trainers. Not models, but individual devices. Hitting + • or slope/erg has resolved the issue. It has to do with device errors. It seems older products/apps have had more time and money to figure out how to catch and recover from these errors. We are working on improvements on how to stop this from happening.

If you can tell me all the devices you have and/or if you can repeat this consistently and work with my developer we could fix it.

1 Like

Is the error consistent? Can you repeat it? If yes, then it would be easier for fixing/diagnose

did you try the manual increase of wattage using the +/- buttons? Did that help?

Yes, I just got verification from my developer that we did not change anything recently so this appears to be the same issue other people have had.

As I mentioned, one person with a specific model trainer there is no problem and another with the same model has a problem. My developer will send a second target update after the first one which should reduce or eliminate this happening. I would say this is more likely to happen if you have a ramp into a large power change but I know people experience this without the ramp.

What will end up happening with our fix is that occasionally your interval start would be delayed by 2-seconds when your device has this error condition. Still irratating but we currently don’t see any better solution and a lot better than what it is now. If you could let us know your trainers that would help. We should have this fix in place later this week or next week.

1 Like

Thank you for all of the replies! I’m a newbie to the app so I’ve only used it 3 times. 1st go it was fine then it happened on the second and third times. I tried it on both my phone and tablet and it happened on both. I didn’t try tapping the the + button so will try that for now. My devices are:

Saris H3 trainer using a wahoo cadence sensor.
Google pixel 7 pro
iPad air 2

Many thanks!

Here is a short duration, low intensity workout that should verify your issues

And if it is related to ramps or a second test would be this one.

If these help reproduce the issue reliably then it will make it much easier for my developer to make 100% sure the issue is resolved.

Thanks Alex, I will try that then get back to you.

1 Like

Pixel 7 pro, cool, did not even realize it was out. Yes, Saris H3 seems to be a little more problematic than other devices. Still it’s something that can be resolved with changes in our app.

1 Like

Actually my developer added the first level fix that we hope will fix this, and it will be available today or tomorrow. Ideally you could try above and see if it replicates it today and then try soon with the new build and see if it fixes it.

1 Like


I’ve completed the both tests you suggested on both the iPad air 2 and the Google pixel 7 pro this evening and the results are below.

iPad air 2
ERG Test Ipad

ERG Ramp Test ipad

Pixel 7 pro
ERG Test Pixel 7 Pro

ERG Ramp Test Pixel 7 Pro

Everything seemed much better doing the tests. Only 2 small issues noticed.

  • during the ERG Ramp Test on the iPad it felt like the 4th interval was going to stick but then it corrected itself without intervention after about 2 seconds you can see this in the chart.
  • During the ERG Test on the pixel 7 pro the first low interval was at stuck at the higher wattage. Again you can see this in the chart.

Hope this helps! Thanks for everything!

Oh yes, it looks like both of those case replicated the issue. The reason the ramp test on the 4th interval fixed itself was that during the ramp we keep sending updates every 1 second so eventually one of them worked. Also it’s interesting case in the first example because your device like needed to be warmed up or woken up before it accepted the power change.

The new version 3.4.5 is available on play store now. Apple should get approved later today or tomorrow. My guess is that 3.4.5 will fix it 90+% of the time but rarely it might still occur. I think what we need to do is if you are in ERG and your power does not match your target (or close) in a second or two we need to keep sending power target updates until it fixes itself.

Thanks so much for this.

1 Like

Thanks Alex, really appreciate your help and quick responses! Will download the new app and get going with that.

Thank you


For what it’s worth, I saw this behaviour too and I’m using Elite Suito-T. After seeing this issue I started to do few + increases at workout beginning until I see/feel it acts and move it down back to 100% setting. After doing this it always changes wattage properly in my experience (in the context of one workout).

That’s good feedback. Maybe when we start the workout we need to keep sending updates many times in the start of the workout.

I guess this is the same issue, that I reported one year ago and that‘s still not solved for me: ERG problems related to slope mode - #22 by Alex

When the workout starts with a ramp, there‘s no problem. But when it starts with a steady effort, I have to press the „+“ button a few times or change to slope and back to ERG until ERG kicks in. No problems during the workout. It‘s always during the first minute.

Glad that others have the issue now, too :wink:

TACX Neo 1, iPad

Oh interesting. I should have asked if this was fixed. I have an idea now how to fix this.

I’m not sure if this is the same problem but on my trainer a Stages Sb20 I lose erg mode if I stop pedaling for a few seconds. I have to switch to slope mode or resistance for a bit then I can return to erg.